Discourse Problems


#1

I created a thread ages ago for ‘Hebden Bridge Open Studios - July 2018’. Firstly, @emma couldn’t access this, and then it was only visible when I searched for it. So, I created a new thread ‘Hebden Bridge Open Studios (July 2018)’, moved the posts to that & deleted the old one. The new thread is visible, but @emma still can’t view it. Her trust level is set as ‘2 - Member’. Would someone please tell me what I’m doing wrong/ not doing?! Thanks.


#2

@RoboGuy I’ve had a look and don’t see much different between @emma 's account and mine, which can see the new thread.
Emma, have you tried different browsers?


#3

Ok, I have ‘moderator’ flag set. Emma and Steve don’t. Can’t see why that would cause the symptoms, but it is a difference I’ve noticed.


#4

Just commented on that other thread. Trust Level 2 Member means nothing. You need to be added to the “Members” group. Just done this for a few folk. @paul123, see the admin link I posted in the other thread.


#5

Thanks, @9600. Please advise where that’s done - I need to flag a few more members now I can see it.


#6

Ignore that request, @9600, I’ve seen your comment in the other thread now. I think I just couldn’t see it for looking. I’ve amended the setting for a few members.


#7

This means very little to me, but . . . .apparently Discourse doesn’t work with IPV6, but DNS is apparently set up. Can somebody please fix the web server - @treb0r or @9600 or . . . ?


#8

Website and Discourse appear to be working fine to me. Where are you seeing issues? A verbatim error would be useful.


#9

Ben was seeing Error 44. I’m sure @picus can explain much better than me - please advise @9600! I’m aware Pat’s had problems with the forum, so may be the same issue? They don’t have IDs because haven’t been able to register.


#10

It was just giving Ben a 404. It looks like the ipv6 “AAAA” records are set up for the site at DNS level (or at least a wildcard subdomain) but the corresponding set up hasn’t been done at the web server end of things. All my web server work had been ipv4 set up and Apache or I’d be able to say exactly what needs setting up…


#11

I’ve just been emailing a few people because I know they’ve never been able to access Discourse due to this. Ben’s reminded me that he’d like to use Discourse if only this can be fixed. I know @picus suggested moving to Slack instead. Whatever the choice, can we please get something that everybody can access?


#12

After the ten minutes I spent trying to convince Pat of the merits of WhatsApp the other day good luck finding an alternative that we can/will all use :joy:

Slack may be a good choice, and free, I’d mentioned WhatsApp to Pat as an easier way of us co-ordinating being there to open on Wednesdays as I only occasionally get notification emails when people tag me on discourse, but Slack would/could provide a nice combination of group chats and threads on specific subjects as well as messaging.


#13

Hi - I’ve now put a static hosts entry in just to get discourse to work - unfortunately it’s not that easy on a phone or tablet!

I’d be really grateful if whoever looks after it could fix the site config for IPv6 - I can help if whoever it is, is struggling.

(Oh, and all the extra spaces in the FQDNs are because discourse thinks they are links and says new users can only post 2 - SIGH - facebook group anyone? )

Thanks,

Ben

All the information on the issue needed is here:

dig +short A discourse . bridgerectifier . org . uk
calder . bridgerectifier . org . uk.
46.101.77.219

telnet 46.101.77.219 80
Trying 46.101.77.219…
Connected to calder . bridgerectifier . org . uk.
Escape character is ‘^]’.
GET / HTTP/1.1
Host: discourse . bridgerectifier . org . uk

HTTP/1.1 200 OK
Server: nginx/1.10.3 (Ubuntu)
Date: Wed, 02 Jan 2019 10:39:49 GMT

dig +short AAAA discourse . bridgerectifier . org . uk
calder.bridgerectifier.org.uk.
2a03:b0c0:1:d0::c2:c001

telnet 2a03:b0c0:1:d0::c2:c001 80
Trying 2a03:b0c0:1:d0::c2:c001…
Connected to calder . bridgerectifier . org . uk.
Escape character is ‘^]’.
GET / HTTP/1.1
Host: discourse . bridgerectifier . org . uk

HTTP/1.1 404 Not Found
Server: nginx/1.10.3 (Ubuntu)
Date: Wed, 02 Jan 2019 10:40:55 GMT


#14

Sorry, bit strapped for time to figure this out right now, so if you can just tell me what records need setting up or changing.


#15

Without seeing the nginx config (which feel free to email me) I suspect: listen [::]:80; is missing from the site config for discourse and it’s falling back to the default server.

Look for
listen 80;
and add
listen [::]:80;

After it.


#16

It’s a Docker container and looking at it with docker inspect app, I couldn’t see anything IPv6 specific.

I’ve just done a launcher rebuild app, which has upgraded Discourse. I think we’d been running the previous build for quite some time.

Not sure if that’s helped? If not, will have to look into IPv6 Discourse config. Presumably it would be set when you first run up the container (which wasn’t done by me), instead of hacking away at config files inside it.


#17

Rob set up the website and discourse forum, but due to other commitments he’s asked that others take over administration of this now. Who’s up for that? I’ve got access to edit stuff on the website, but have only ever added occasional posts to the home page, eg to promote laser cutting intro days.


#18

I’ve been looking after Discourse and the server it runs on, plus the server the website runs on. Happy to continue doing this, but don’t want to take on website copy editing.